DllNotFoundException: lib64/libode-x86_64

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

DllNotFoundException: lib64/libode-x86_64

Jeff Kelley
Hi.

It seems that commit 073877d (ODE lib: update the lib for linux
64bit) has introduced a dependency on glibc 2.14, raising a
DllNotFoundException when running a ODE/ubODE simulator with an older
glibc :

http://opensimulator.org/mantis/view.php?id=7804

Unfortunately, upgrading glibc past the version supported by a distro
is not possible. This rules out (for example) RHEL 6, Debian 6 and
maybe 7, and Ubuntu 10.

https://en.wikipedia.org/wiki/GNU_C_Library#Version_history

I think there is a choice to make here : either require glibc >= 2.14
and subsequently raise the version for qualified Linux distros ; or
rebuild the libs with a pre 2.14 glibc.

What the team thinks?


-- Jeff





The memcpy vs. memmove saga :
https://www.win.tue.nl/~aeb/linux/misc/gcc-semibug.html



_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: DllNotFoundException: lib64/libode-x86_64

Jak Daniels
Hi all,

I think that libraries for linux should always be built on the oldest
but still supported (with security updates) distro... for example
centos/Rhel 5.  They will always work on the newer distros as they
always have a compat glibc. I don't see the advantage in building on the
latest and greatest distro and effectively then excluding their use on
older systems especially as many VPS offerings still only provide Centos
5 and 6 and earlier Ubuntus. It's the same principle as jenkins building
Opensim on Mono 2.10.8 as a base line minimum version to ensure
compatibility. I remember we had this issue with Bulletsim.so not
working on RHEl5 due to it being built on a new system. Why shouldn't it
be possible to run Opensim on a linux system that is still receiving
security updates from the vendor? There would be uproar if we couldn't
run it on say Windows 7.

Jak


On 21/01/2016 07:54, Jeff Kelley wrote:

> Hi.
>
> It seems that commit 073877d (ODE lib: update the lib for linux 64bit)
> has introduced a dependency on glibc 2.14, raising a
> DllNotFoundException when running a ODE/ubODE simulator with an older
> glibc :
>
> http://opensimulator.org/mantis/view.php?id=7804
>
> Unfortunately, upgrading glibc past the version supported by a distro
> is not possible. This rules out (for example) RHEL 6, Debian 6 and
> maybe 7, and Ubuntu 10.
>
> https://en.wikipedia.org/wiki/GNU_C_Library#Version_history
>
> I think there is a choice to make here : either require glibc >= 2.14
> and subsequently raise the version for qualified Linux distros ; or
> rebuild the libs with a pre 2.14 glibc.
>
> What the team thinks?
>
>
> -- Jeff
>
>
>
>
>
> The memcpy vs. memmove saga :
> https://www.win.tue.nl/~aeb/linux/misc/gcc-semibug.html
>
>
>
> _______________________________________________
> Opensim-dev mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: DllNotFoundException: lib64/libode-x86_64

Zadark Portal
An alternative would be to compile ODE libraries locally. 

git clone git://opensimulator.org/git/opensim-libs       .. folder trunk/unmanaged holds the sources for the physics libraries. Recent updates appear to be for 'OpenDynamicsEngine-0.13.1mod' so I assume this to be the version used with Opensim.

Not used the ode myself but I have successfully tinkered with the bulletsim libraries.

Z

On 21 January 2016 at 22:23, Jak Daniels <[hidden email]> wrote:
Hi all,

I think that libraries for linux should always be built on the oldest but still supported (with security updates) distro... for example centos/Rhel 5.  They will always work on the newer distros as they always have a compat glibc. I don't see the advantage in building on the latest and greatest distro and effectively then excluding their use on older systems especially as many VPS offerings still only provide Centos 5 and 6 and earlier Ubuntus. It's the same principle as jenkins building Opensim on Mono 2.10.8 as a base line minimum version to ensure compatibility. I remember we had this issue with Bulletsim.so not working on RHEl5 due to it being built on a new system. Why shouldn't it be possible to run Opensim on a linux system that is still receiving security updates from the vendor? There would be uproar if we couldn't run it on say Windows 7.

Jak



On 21/01/2016 07:54, Jeff Kelley wrote:
Hi.

It seems that commit 073877d (ODE lib: update the lib for linux 64bit) has introduced a dependency on glibc 2.14, raising a DllNotFoundException when running a ODE/ubODE simulator with an older glibc :

http://opensimulator.org/mantis/view.php?id=7804

Unfortunately, upgrading glibc past the version supported by a distro is not possible. This rules out (for example) RHEL 6, Debian 6 and maybe 7, and Ubuntu 10.

https://en.wikipedia.org/wiki/GNU_C_Library#Version_history

I think there is a choice to make here : either require glibc >= 2.14 and subsequently raise the version for qualified Linux distros ; or rebuild the libs with a pre 2.14 glibc.

What the team thinks?


-- Jeff





The memcpy vs. memmove saga :
https://www.win.tue.nl/~aeb/linux/misc/gcc-semibug.html



_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev


_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Loading...