.NET 3.5 components still seem to be needed for Windows Compile

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

.NET 3.5 components still seem to be needed for Windows Compile

Ai Austin-2
When I set up a new system - with a clean Windows 8.1 Pro install -
and then install Visual C# Express as required on FIRST use of this
for runprebuild.bat and compile.bat of the core OpenSim systems,
Windows reports a missing component for .NET 3.5 and offers to
download and install that.  This is the component it reports is installed...

.NET Framework 3.5 (includes .NET 2.0 and 3.0)

It works after that is done. This is the case with the latest dev master.

  have noticed this before when I have set up a new computer for
OpenSimulator core compilation... and wonder if its intended?  Or
whether some component is requiring .NET3.5 that should be set to use
.NET 4.0 now?

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: .NET 3.5 components still seem to be needed for Windows Compile

Dahlia Trimble
A while back I changed prebuild.exe to use .NET 3.5. Not sure if this is related to your problem but I did it because newer versions of Mono (3.99+) only had support for .NET framework 3.5 and above and the existing prebuild would not work with them. I believe later versions of Microsoft .NET have full support for earlier versions and as such prebuild works with them. My Windows 8.1 dev laptop only has .NET 4.5 and 4.6 and it runs prebuild just fine.

On Mon, Jul 27, 2015 at 6:22 AM, Ai Austin <[hidden email]> wrote:
When I set up a new system - with a clean Windows 8.1 Pro install - and then install Visual C# Express as required on FIRST use of this for runprebuild.bat and compile.bat of the core OpenSim systems, Windows reports a missing component for .NET 3.5 and offers to download and install that.  This is the component it reports is installed...

.NET Framework 3.5 (includes .NET 2.0 and 3.0)

It works after that is done. This is the case with the latest dev master.

 have noticed this before when I have set up a new computer for OpenSimulator core compilation... and wonder if its intended?  Or whether some component is requiring .NET3.5 that should be set to use .NET 4.0 now?

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev


_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Loading...