OpenSimulator will require .Net Framework version 4.6

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

OpenSimulator will require .Net Framework version 4.6

AJLDuarte
 I am sorry to announce that future releases of OpenSimulator will require
.Net Framework version 4.6

 For Windows this means that XP will no longer be supported.
 Other versions, either old or very recent may need to install this version.
 See
https://docs.microsoft.com/en-us/dotnet/framework/get-started/system-require
ments

 For Linux and other platforms a recent version of Mono will be required.
Considering the evolution of the releases rate of Mono, Mono 5.12 seems the
best option.

 Soon our git master branch will be updated with new code (from httptests
branch) with this requirement.

 We would like to see all of you testing our new ways to break your
inventories, regions or even crash your machines. This may actually happen
with Dev versions! So unless you have the skills to gracefully fix a
catastrophic Opensim fail, please be patient and use older, more tested
versions.
(No 0.8.x fans I am not talking to you)

Regards,
Ubit


_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|

Re: OpenSimulator will require .Net Framework version 4.6

Grid Master
Moving out of the dark ages finally ... Very cool ..

On Fri, Jul 6, 2018 at 2:53 PM, AJLDuarte <[hidden email]> wrote:

>  I am sorry to announce that future releases of OpenSimulator will require
> .Net Framework version 4.6
>
>  For Windows this means that XP will no longer be supported.
>  Other versions, either old or very recent may need to install this
> version.
>  See
> https://docs.microsoft.com/en-us/dotnet/framework/get-
> started/system-require
> ments
>
>  For Linux and other platforms a recent version of Mono will be required.
> Considering the evolution of the releases rate of Mono, Mono 5.12 seems the
> best option.
>
>  Soon our git master branch will be updated with new code (from httptests
> branch) with this requirement.
>
>  We would like to see all of you testing our new ways to break your
> inventories, regions or even crash your machines. This may actually happen
> with Dev versions! So unless you have the skills to gracefully fix a
> catastrophic Opensim fail, please be patient and use older, more tested
> versions.
> (No 0.8.x fans I am not talking to you)
>
> Regards,
> Ubit
>
>
> _______________________________________________
> Opensim-dev mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
>
_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|

Re: OpenSimulator will require .Net Framework version 4.6

Michel Beauregard
UBit,

do we consider the latest release  0.9.0.1 (released on June 30, 2018) as the  last version still compatible with older XP and mono 3.x ?


Will Hypergrid  compatiblility be maintained for hypergrid jumps  between  grids running  new git master  in test mode and the 0821 former release  and the 0901 latest release or is there a departure of compatibilities to be expected on the hypergrid standpoint  .

Thanks for the hard work and replies on above.

GiMiSa

 
On Fri, Jul 6, 2018 at 2:53 PM, AJLDuarte <[hidden email]> wrote:

>  I am sorry to announce that future releases of OpenSimulator will require
> .Net Framework version 4.6
>
>  For Windows this means that XP will no longer be supported.
>  Other versions, either old or very recent may need to install this
> version.
>  See
> https://docs.microsoft.com/en-us/dotnet/framework/get-
> started/system-require
> ments
>
>  For Linux and other platforms a recent version of Mono will be required.
> Considering the evolution of the releases rate of Mono, Mono 5.12 seems the
> best option.
>
>  Soon our git master branch will be updated with new code (from httptests
> branch) with this requirement.
>
>  We would like to see all of you testing our new ways to break your
> inventories, regions or even crash your machines. This may actually happen
> with Dev versions! So unless you have the skills to gracefully fix a
> catastrophic Opensim fail, please be patient and use older, more tested
> versions.
> (No 0.8.x fans I am not talking to you)
>
> Regards,
> Ubit

 
_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|

our git master branch is again main development branch

AJLDuarte
In reply to this post by AJLDuarte
Hi,
        Our git master branch was updated with our development work on
httptests.
        This way it is again our main development branch.
        The new requirements apply to it

        - you can follow its changes at [1]
        - you can get a clone of it [2]
        - build it [3]
        - submit your good code changes [4]

        Let us know about any issues, request new features, etc [5]

        Note that we may still release code fixes to series 0.9.0.x, if
those fixes are important and are not complex.
        Those releases will have the 0.9.0.x requirements (.net4.0, mono
>2.10.8..).

Regards,
Ubit

[1] http://opensimulator.org/viewgit/?a=shortlog&p=opensim&h=HEAD&pg=0
[2]
http://opensimulator.org/wiki/Developer_Documentation#Source_Code_Repository
_Access
[3] http://opensimulator.org/wiki/Build_Instructions
[4] http://opensimulator.org/wiki/Submitting_code_to_OpenSim
[5] http://opensimulator.org/mantis




_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|

Re: our git master branch is again main development branch

Mike Dickson
I get the submitting patches approach for changes but I really wish there
was a more modern workflow like pull requests with an opportunity for
review. It provides a mechanism to supply the patches and capture comments
and changes directly.  Any chance of moving to something like that with all
the brave new world changes being made?

Mike

-----Original Message-----
From: [hidden email]
<[hidden email]> On Behalf Of AJLDuarte
Sent: Saturday, July 07, 2018 12:17 PM
To: [hidden email]; [hidden email]
Subject: [Opensim-dev] our git master branch is again main development
branch

Hi,
        Our git master branch was updated with our development work on
httptests.
        This way it is again our main development branch.
        The new requirements apply to it

        - you can follow its changes at [1]
        - you can get a clone of it [2]
        - build it [3]
        - submit your good code changes [4]

        Let us know about any issues, request new features, etc [5]

        Note that we may still release code fixes to series 0.9.0.x, if
those fixes are important and are not complex.
        Those releases will have the 0.9.0.x requirements (.net4.0, mono
>2.10.8..).

Regards,
Ubit

[1] http://opensimulator.org/viewgit/?a=shortlog&p=opensim&h=HEAD&pg=0
[2]
http://opensimulator.org/wiki/Developer_Documentation#Source_Code_Repository
_Access
[3] http://opensimulator.org/wiki/Build_Instructions
[4] http://opensimulator.org/wiki/Submitting_code_to_OpenSim
[5] http://opensimulator.org/mantis




_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|

Re: our git master branch is again main development branch

AJLDuarte
Hi,
        No plans to add that for the moment, sorry
Ubit

-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Mike Dickson
Sent: Saturday, July 07, 2018 18:08
To: [hidden email]
Subject: Re: [Opensim-dev] our git master branch is again main development
branch

I get the submitting patches approach for changes but I really wish there
was a more modern workflow like pull requests with an opportunity for
review. It provides a mechanism to supply the patches and capture comments
and changes directly.  Any chance of moving to something like that with all
the brave new world changes being made?

Mike

-----Original Message-----
From: [hidden email]
<[hidden email]> On Behalf Of AJLDuarte
Sent: Saturday, July 07, 2018 12:17 PM
To: [hidden email]; [hidden email]
Subject: [Opensim-dev] our git master branch is again main development
branch

Hi,
        Our git master branch was updated with our development work on
httptests.
        This way it is again our main development branch.
        The new requirements apply to it

        - you can follow its changes at [1]
        - you can get a clone of it [2]
        - build it [3]
        - submit your good code changes [4]

        Let us know about any issues, request new features, etc [5]

        Note that we may still release code fixes to series 0.9.0.x, if
those fixes are important and are not complex.
        Those releases will have the 0.9.0.x requirements (.net4.0, mono
>2.10.8..).

Regards,
Ubit

[1] http://opensimulator.org/viewgit/?a=shortlog&p=opensim&h=HEAD&pg=0
[2]
http://opensimulator.org/wiki/Developer_Documentation#Source_Code_Repository
_Access
[3] http://opensimulator.org/wiki/Build_Instructions
[4] http://opensimulator.org/wiki/Submitting_code_to_OpenSim
[5] http://opensimulator.org/mantis




_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|

Re: OpenSimulator will require .Net Framework version 4.6

Ai Austin-2
In reply to this post by AJLDuarte
I know this is likely to be something simple... but can anyone suggest the fix?

In moving my grids to the new Dev master Framework 4.6 based setup it
all worked fine with runprebuild.bat and compile.bat on 3 of my
systems, but one (apparently near identical Windows 10 latest 1803 in
all cases) setup is showing hundreds of warnings of this form...

>C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Microsoft.Common.targets(983,5):
>warning MSB3644: The reference assemblies for framework
>".NETFramework,Version=v4.6" were not found. To resolve this,
>install the SDK or Targeting Pack for this framework version or
>retarget your application to a version of the framework for which
>you have the SDK or Targeting Pack installed. Note that assemblies
>will be resolved from the Global Assembly Cache (GAC) and will be
>used in place of reference assemblies. Therefore your assembly may
>not be correctly targeted for the framework you intend.


The .NET 4.6 runtime installer says have a later version of .NET
installed 4.7.x I assume. I tried installing the .NET 4.6 targeting
pack and that made no difference, and then the .NET 4.6 SDK.. again no joy.

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|

Re: OpenSimulator will require .Net Framework version 4.6

Ai Austin-2
In reply to this post by AJLDuarte
I installed Visual Studio Community 2017 (3.6GB!) and then it
works... but for some reason just installing the ,NET 4.6 targeting
pack is not enough.  Anyone know what the MINIMUM .NET 4.6
installtion requirement is for the latest Dev master?

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|

Re: OpenSimulator will require .Net Framework version 4.6

AJLDuarte
Mb it only installed runtime until you did installed all the tools?


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Ai Austin
Sent: Monday, July 09, 2018 17:40
To: [hidden email]
Subject: Re: [Opensim-dev] OpenSimulator will require .Net Framework version
4.6

I installed Visual Studio Community 2017 (3.6GB!) and then it
works... but for some reason just installing the ,NET 4.6 targeting
pack is not enough.  Anyone know what the MINIMUM .NET 4.6
installtion requirement is for the latest Dev master?

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|

Re: OpenSimulator will require .Net Framework version 4.6

Ai Austin-2
In reply to this post by AJLDuarte
@Ubit wrote:
 > Mb it only installed runtime until you did installed all the tools?

On first attempt I tried just the .NET 4.6 runtime install and
rebooted.  That did not work.

On second attempt I installed .NET 4.6 targeting pack (it says there
is no SDK for 4.6) and rebooted. Again that did not work.

On third attempt I installed Visual Studio Community 2017 with
developer tools ticked and rebooted and that works.  But its a 3.8GB
or so install, and I wondered if it was strictly necessary to install
so much to have the latest .NET 4.6 based Dev master work?

P.S. Dev Master still says 0.9.1.0 Snail Dev Ubit... did you mean to
drop the "Snail" moniker now the httptests branch is merged back into
the Dev Master branch?

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|

Re: OpenSimulator will require .Net Framework version 4.6

AJLDuarte
Hi
        The name on version is still needed since there are several old
0.9.1Dev no really 0.9.0.1
        To run you only need a "runtime"
        The SDK or targeting pack, guess something went wrong for it not to
be detected by your VS.
        Possible it now wants updated VS ?
Ubit


-----Original Message-----
From: [hidden email]
[mailto:[hidden email]] On Behalf Of Ai Austin
Sent: Monday, July 09, 2018 17:58
To: [hidden email]
Subject: Re: [Opensim-dev] OpenSimulator will require .Net Framework version
4.6

@Ubit wrote:
 > Mb it only installed runtime until you did installed all the tools?

On first attempt I tried just the .NET 4.6 runtime install and
rebooted.  That did not work.

On second attempt I installed .NET 4.6 targeting pack (it says there
is no SDK for 4.6) and rebooted. Again that did not work.

On third attempt I installed Visual Studio Community 2017 with
developer tools ticked and rebooted and that works.  But its a 3.8GB
or so install, and I wondered if it was strictly necessary to install
so much to have the latest .NET 4.6 based Dev master work?

P.S. Dev Master still says 0.9.1.0 Snail Dev Ubit... did you mean to
drop the "Snail" moniker now the httptests branch is merged back into
the Dev Master branch?

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev