Re: [OpenSim-dev] First time setup of OpenSim - paths to configure

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [OpenSim-dev] First time setup of OpenSim - paths to configure

Ai Austin-2
I am finding out more works than we indicate when going through the
various .ini setup files.. initially for Standalone configurations..
but I plan to follow with MySQL and grid setups.

The comments in config-include/StandaloneCommon.ini.example indicate
that the various [GridInfoService] settings for these 5 things are
"currently used".
    *     welcome =

    *     about =

    *     register =

    *     help =

    *     password =
However, they all work fine and properly communicate the values to
the grid managers on several viewers I have tested.

The undocumented [GridInfoService] "message" URL also works on both
standalones and Robust grids.

DestinationGuide does NOT seem to work for standalones, but works
fine for Robust grids.  Any idea why that might be the case
@BlueWall, as I think you implemented that part?

As I mentioned before groups, OfflineIM and some errors with
UserProfiles all mean these don't work on my tests with
Standalones/SQLite.. though I am not sure if that is because they are
not meant to work, or that I am not following instructions correctly,
or the instructions are misleading for the Standalone/SQLite case.

@Diva, would we expect your core provided Groups V2 and Offline IM
V2  to work with Standalone/SQLite?  Errors are thrown that "no
storage interface for SQLite is in the module".  So maybe MySQL is
compulsory for these addon features?  If so a comment to that effect
may be all that is needed, as the current instuctions imply the
modules work with Standalones and don't specify a specific data base
must be used.

@BlueWall, would you expect UserProfiles to work with
Stanalone/SQLite setup?  I reported a mantis issue on this if it
should work. http://opensimulator.org/mantis/view.php?id=7704

Thanks for your patience everyone and I hope you don't mind too much
if I finish off my questions and get comments for fixes via this
list. They are a bit too broad to make a whole series of Mantis
entries for except where I come across specific errors in my tests.

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [OpenSim-dev] First time setup of OpenSim - paths to configure

Melanie-2
As I review the patches to clarify first time setup, I became aware
that the .ini.example method of configuring is being used for the
Flotsam cache. This appears unnecessary as most people never change
any of these settings anyway. That makes copying the .ini.example to
.ini just an extra, avoidable step in the configuration of OpenSim.

As I see it, we could just as well ship Flotsam's config file as
.ini to eliminate that step. The .ini.example method should really
only be used where the user _must_ edit a file, not just because we can.

- Melanie

On 26/08/2015 15:05, Ai Austin wrote:

> I am finding out more works than we indicate when going through the
> various .ini setup files.. initially for Standalone configurations..
> but I plan to follow with MySQL and grid setups.
>
> The comments in config-include/StandaloneCommon.ini.example indicate
> that the various [GridInfoService] settings for these 5 things are
> "currently used".
>     *     welcome =
>
>     *     about =
>
>     *     register =
>
>     *     help =
>
>     *     password =
> However, they all work fine and properly communicate the values to
> the grid managers on several viewers I have tested.
>
> The undocumented [GridInfoService] "message" URL also works on both
> standalones and Robust grids.
>
> DestinationGuide does NOT seem to work for standalones, but works
> fine for Robust grids.  Any idea why that might be the case
> @BlueWall, as I think you implemented that part?
>
> As I mentioned before groups, OfflineIM and some errors with
> UserProfiles all mean these don't work on my tests with
> Standalones/SQLite.. though I am not sure if that is because they are
> not meant to work, or that I am not following instructions correctly,
> or the instructions are misleading for the Standalone/SQLite case.
>
> @Diva, would we expect your core provided Groups V2 and Offline IM
> V2  to work with Standalone/SQLite?  Errors are thrown that "no
> storage interface for SQLite is in the module".  So maybe MySQL is
> compulsory for these addon features?  If so a comment to that effect
> may be all that is needed, as the current instuctions imply the
> modules work with Standalones and don't specify a specific data base
> must be used.
>
> @BlueWall, would you expect UserProfiles to work with
> Stanalone/SQLite setup?  I reported a mantis issue on this if it
> should work. http://opensimulator.org/mantis/view.php?id=7704
>
> Thanks for your patience everyone and I hope you don't mind too much
> if I finish off my questions and get comments for fixes via this
> list. They are a bit too broad to make a whole series of Mantis
> entries for except where I come across specific errors in my tests.
>
> _______________________________________________
> Opensim-dev mailing list
> [hidden email]
> http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
>
>
_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Loading...