Requested method [locate_user] not found

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Requested method [locate_user] not found

Fred Beckhusen
New problem has crept in and I don't know where to look next. It appears
that the HTTP Handler handler for XML is not registering or crashing
when a NPC or a HG visitor arrives.  You can log into a region directly.

OSgrid OpenSimulator 0.9.1.dev.24df1086fa  compiled on Windows 10 with
Diva extensions.  On startup, NPCs and HG visitors cause a Yellow
WARN.   there are no other ERRORs.   You can see the region on the map
and it will start the tp to the region, but Firestorm immediately
crashes.  Crashes for HG or Grid users.   The last thing Firestorm log
has that is 'normal' is:

2018-09-11T19:41:56Z INFO: newview/llviewerregion.cpp(1004) :
LLViewerRegion::processRegionInfo: Processing region info

And then a crash dump happens and FS exits.

I've seen this on two different grids.  I realized it might be the
"0.9.0.1 Robust excessive use of memory fix" by AJLDuarte, which
replaces the HTTPServer,  but putting back the original HTTPServer DLL
and PDB does not change the symptoms.

Here is a short region view of it:

2018-09-11 11:04:04,525 INFO [SCENE PRESENCE]: Completing movement of Dj
John David into region Tropical Island in position <136.5911, 201.3606,
29.81383>

2018-09-11 11:04:04,552 INFO  [XEngine]: Started 200 scripts in Tropical Island
2018-09-11 11:04:04,750 INFO  [XEngine]: Started 500 scripts in NYC
2018-09-11 11:04:04,763 INFO  [XEngine]: Started 200 scripts in Town of Haven
2018-09-11 11:04:04,839 INFO  [XEngine]: Started 550 scripts in NYC
2018-09-11 11:04:05,100 INFO  [XEngine]: Started 250 scripts in Tropical Island
2018-09-11 11:04:05,191 INFO  [XEngine]: Started 600 scripts in NYC
2018-09-11 11:04:05,193 INFO  [XEngine]: Started 250 scripts in Town of Haven
2018-09-11 11:04:05,198 INFO  [XEngine]: Completed starting 273 scripts on Tropical Island
2018-09-11 11:04:06,722 WARN  [HG IM SERVICE]: LocateUser call failed
System.Exception: [USER AGENT CONNECTOR]: locate_user call tohttp://192.168.0.3:8003  returned an error: Requested method [locate_user] not found
    at OpenSim.Services.Connectors.Hypergrid.UserAgentServiceConnector.CallServer(String methodName, Hashtable hash) in c:\Opensim\Outworldz Dreamgrid Source\OutworldzFiles\Opensim\OpenSim\Services\Connectors\Hypergrid\UserAgentServiceConnector.cs:line 195
    at OpenSim.Services.Connectors.Hypergrid.UserAgentServiceConnector.LocateUser(UUID userID) in c:\Opensim\Outworldz Dreamgrid Source\OutworldzFiles\Opensim\OpenSim\Services\Connectors\Hypergrid\UserAgentServiceConnector.cs:line 524
    at OpenSim.Services.HypergridService.HGInstantMessageService.TrySendInstantMessage(GridInstantMessage im, Object previousLocation, Boolean firstTime, Boolean foreigner) in c:\Opensim\Outworldz Dreamgrid Source\OutworldzFiles\Opensim\OpenSim\Services\HypergridService\HGInstantMessageService.cs:line 227

Any ideas where to start to look?

A full set of a region log and robust log with level DEBUG is at
www.dropbox.com/s/uh85tngxbuxnosc/THGLogs.zip?dl=1

--
--ooo------/\/\/\-----|(------ooo------/\/\/\-----|(------ooo----
Fred K. Beckhusen
President
Micro Technology Services, Inc.
[hidden email]
tel: (888) 230-MTSI Toll Free
cel: (469) 951-7635
http://www.mitsi.com

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev