What format should be used with region_info_source = web

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

What format should be used with region_info_source = web

Jeff Kelley
The text version doesn't work.

I tried the XML format documented here
http://opensimulator.org/wiki/OpenSim_0.6.6_legacy_configuration_information
and it bombs at CheckRegionsForSanity.

I tried the Nini format discussed here
http://opensimulator.org/pipermail/opensim-dev/2014-April/024752.html
and it bombs at XmlConfigureSource.LoadSections.

Failing examples:

<Section name="Region_1"><key name="RegionName" value="Reg01" /><key
name="RegionUUID" value="27751610-ee06-40d4-b35d-0d3efe37cbf7" /><key
name="Location" value="4001,4000" /><key name="InternalPort"
value="9101" /><key name="InternalAddress" value="0.0.0.0" /><key
name="AllowAlternatePorts" value="false" /><key
name="ExternalHostName" value="88.161.20.136" /></Section>


<Section name="Region_1"><key name="RegionUUID"
value="186df228-71e7-4890-aa9e-1349605ac7c0" /><key name="name"
value="Reg01" /><key name="location_x" value="4001" /><key
name="location_y" value="4000" /><key name="InternalPort"
value="9101" /><key name="internal_ip_address" value="0.0.0.0" /><key
name="allow_alternate_ports" value="false" /><key
name="external_host_name" value="88.161.20.136" /></Section>


What is the correct format for loading from web?


Opensim 0.8.2.0


-- Jeff

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What format should be used with region_info_source = web

ssm2017
the OpenSim.ini file is saying :
    ;# {regionload_webserver_url} {region_info_source} {URL to load region from?} {}
    ;; Determines the page from which regions xml is retrieved if you are
    ;; loading these from the web.
    ;; The XML here has the same format as it does on the filesystem
    ;; (including the <Root> tag), except that everything is also enclosed
    ;; in a <Regions> tag.
    ; regionload_webserver_url = "http://example.com/regions.xml";
it looks like the example furnished in the "share" folder.
https://github.com/opensim/opensim/tree/master/share/RegionLoading
if this is not the good format, maybe someone can update the OpenSim.ini comments, and the wiki page :
http://opensimulator.org/wiki/Configuring_Regions


On Wed, Nov 25, 2015 at 10:59 AM, Jeff Kelley <[hidden email]> wrote:
The text version doesn't work.

I tried the XML format documented here
http://opensimulator.org/wiki/OpenSim_0.6.6_legacy_configuration_information
and it bombs at CheckRegionsForSanity.

I tried the Nini format discussed here
http://opensimulator.org/pipermail/opensim-dev/2014-April/024752.html
and it bombs at XmlConfigureSource.LoadSections.

Failing examples:

<Section name="Region_1"><key name="RegionName" value="Reg01" /><key name="RegionUUID" value="27751610-ee06-40d4-b35d-0d3efe37cbf7" /><key name="Location" value="4001,4000" /><key name="InternalPort" value="9101" /><key name="InternalAddress" value="0.0.0.0" /><key name="AllowAlternatePorts" value="false" /><key name="ExternalHostName" value="88.161.20.136" /></Section>


<Section name="Region_1"><key name="RegionUUID" value="186df228-71e7-4890-aa9e-1349605ac7c0" /><key name="name" value="Reg01" /><key name="location_x" value="4001" /><key name="location_y" value="4000" /><key name="InternalPort" value="9101" /><key name="internal_ip_address" value="0.0.0.0" /><key name="allow_alternate_ports" value="false" /><key name="external_host_name" value="88.161.20.136" /></Section>


What is the correct format for loading from web?


Opensim 0.8.2.0


-- Jeff

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev


_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What format should be used with region_info_source = web

thai low (endivatomic.eu)
In reply to this post by Jeff Kelley
After some hours of @@@!!!###! i arrived to this:

   <Nini>
    <Section Name="My region Name">
      <Key Name="RegionUUID" Value="4208aa66-ce9b-4f49-a4da-06a27d95f001" />   
      <Key Name="Location" Value="7000,7000" />   
      <Key Name="SizeX" Value="256" />
      <Key Name="SizeY" Value="256" />
      <Key Name="InternalAddress" Value="0.0.0.0" />
      <Key Name="InternalPort" Value="9016" />
      <Key Name="AllowAlternatePorts" Value="False" />
      <Key Name="ExternalHostName" Value="endivatomic.eu" />
      <Key Name="MaxPrims" Value="15000" />
      <Key Name="MaxAgents" Value="40" />
      <Key Name="RegionType" Value="0" />
      <Key Name="MaptileStaticUUID" Value="00000000-0000-0000-0000-000000000000" />
    </Section>
   </Nini>

Be careful:
    NewLine needed at end of line
    Tabs needed at beginning
    Caps letter and spaces MUST be exactly like showed

if u want a php example contact me by mail.



Il 27/11/2015 13:00, [hidden email] ha scritto:
Oggetto:
[Opensim-dev] What format should be used with region_info_source = web
Mittente:
Jeff Kelley [hidden email]
Data:
25/11/2015 10:59
A:
[hidden email]

The text version doesn't work.

I tried the XML format documented here
http://opensimulator.org/wiki/OpenSim_0.6.6_legacy_configuration_information
and it bombs at CheckRegionsForSanity.

I tried the Nini format discussed here
http://opensimulator.org/pipermail/opensim-dev/2014-April/024752.html
and it bombs at XmlConfigureSource.LoadSections.

Failing examples:

<Section name="Region_1"><key name="RegionName" value="Reg01" /><key name="RegionUUID" value="27751610-ee06-40d4-b35d-0d3efe37cbf7" /><key name="Location" value="4001,4000" /><key name="InternalPort" value="9101" /><key name="InternalAddress" value="0.0.0.0" /><key name="AllowAlternatePorts" value="false" /><key name="ExternalHostName" value="88.161.20.136" /></Section>


<Section name="Region_1"><key name="RegionUUID" value="186df228-71e7-4890-aa9e-1349605ac7c0" /><key name="name" value="Reg01" /><key name="location_x" value="4001" /><key name="location_y" value="4000" /><key name="InternalPort" value="9101" /><key name="internal_ip_address" value="0.0.0.0" /><key name="allow_alternate_ports" value="false" /><key name="external_host_name" value="88.161.20.136" /></Section>


What is the correct format for loading from web?


Opensim 0.8.2.0


_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: What format should be used with region_info_source = web

Jeff Kelley
Re: [Opensim-dev] What format should be used with region_
At 1:47 PM +0100 11/27/15, thai low (endivatomic.eu) wrote:


<Nini>
<Section Name="My region Name">
<Key Name="RegionUUID" Value="4208aa66-ce9b-4f49-a4da-06a27d95f001" />
<Key Name="Location" Value="7000,7000" />
<Key Name="SizeX" Value="256" />
<Key Name="SizeY" Value="256" />
<Key Name="InternalAddress" Value="0.0.0.0" />
<Key Name="InternalPort" Value="9016" />
<Key Name="AllowAlternatePorts" Value="False" />
<Key Name="ExternalHostName" Value="endivatomic.eu" />
<Key Name="MaxPrims" Value="15000" />
<Key Name="MaxAgents" Value="40" />
<Key Name="RegionType" Value="0" />
<Key Name="MaptileStaticUUID" Value="00000000-0000-0000-0000-000000000000" />
</Section>
</Nini>


That worked. Thanks thai.

I'll document that on the wiki soon.


-- Jeff

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Loading...