opensim 0.9 robust timestamp error

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

opensim 0.9 robust timestamp error

R.Gunther
Just installed a ferw days ago own grid. it's now running.
Today in the logs a mysql timestamp error appeared, that can never be good.
Is this a bug ? something else wrong ? mabye it's already fixt. Or mabye
i need to fix something.

MySql.Data.MySqlClient.MySqlException (0x80004005): Incorrect datetime
value: '1459532289' for column 'TMStamp' at row 1
    at MySql.Data.MySqlClient.MySqlStream.ReadPacket()
    at MySql.Data.MySqlClient.NativeDriver.GetResult(Int32& affectedRow,
Int32& insertedId)
    at MySql.Data.MySqlClient.Driver.NextResult(Int32 statementId)
    at MySql.Data.MySqlClient.MySqlDataReader.NextResult()
    at MySql.Data.MySqlClient.MySqlCommand.ExecuteReader(CommandBehavior
behavior)
    at MySql.Data.MySqlClient.MySqlCommand.ExecuteNonQuery()
    at OpenSim.Data.MySQL.MySqlFramework.ExecuteNonQuery(MySqlCommand
cmd) in v:\opensim 0.9dev\OpenSim\Data\MySQL\MySQLFramework.cs:line 73
2016-04-15 19:38:10,502 ERROR (128) -
OpenSim.Data.MySQL.MySqlFramework    at
System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
    at System.Environment.get_StackTrace()
    at OpenSim.Data.MySQL.MySqlFramework.ExecuteNonQuery(MySqlCommand
cmd) in v:\opensim 0.9dev\OpenSim\Data\MySQL\MySQLFramework.cs:line 73
    at OpenSim.Data.MySQL.MySqlGroupsInvitesHandler.DeleteOld() in
v:\opensim 0.9dev\OpenSim\Data\MySQL\MySQLGroupsData.cs:line 437
    at OpenSim.Data.MySQL.MySQLGroupsData.DeleteOldInvites() in
v:\opensim 0.9dev\OpenSim\Data\MySQL\MySQLGroupsData.cs:line 299
    at OpenSim.Groups.GroupsService.m_CleanupTimer_Elapsed(Object
sender, ElapsedEventArgs e) in v:\opensim
0.9dev\OpenSim\Addons\Groups\Service\GroupsService.cs:line 124
    at System.Timers.Timer.MyTimerCallback(Object state)
    at System.Threading.ExecutionContext.RunInternal(ExecutionContext
executionContext, ContextCallback callback, Object state, Boolean
preserveSyncCtx)
    at System.Threading.ExecutionContext.Run(ExecutionContext
executionContext, ContextCallback callback, Object state, Boolean
preserveSyncCtx)
    at System.Threading.TimerQueueTimer.CallCallback()
    at System.Threading.TimerQueueTimer.Fire()
    at System.Threading.TimerQueue.FireNextTimers()

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: opensim 0.9 robust timestamp error

Ai Austin-2
R.Gunther wrote:
>Just installed a few days ago own grid. it's now running.
>Today in the logs a mysql timestamp error appeared, that can never be good.
>Is this a bug ? something else wrong ? mabye it's already fixt. Or mabye
>i need to fix something.
>
>MySql.Data.MySqlClient.MySqlException (0x80004005): Incorrect datetime
>value: '1459532289' for column 'TMStamp' at row 1


Its an issue with 0.9.0 already reported and still open on Mantis at
http://opensimulator.org/mantis/view.php?id=7848
and occurring on our own grid too.

According to Jeff Kelly there, it looks like some Unix time stamp
code has crept in where os_groups_invites.TMStamp is a MySQL TIMESTAMP

I found various parts of OpenSim/Addons/Groups/GroupsModule.cs that
use msg.timestamp = (uint)Util.UnixTimeSinceEpoch();

You can mask (but not correct) the error by removing
STRICT_TRANS_TABLES and strict settings in the MySQL my.ini file.

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: opensim 0.9 robust timestamp error

R.Gunther
On 17-Apr-2016 17:25, Ai Austin wrote:

> R.Gunther wrote:
>> Just installed a few days ago own grid. it's now running.
>> Today in the logs a mysql timestamp error appeared, that can never be
>> good.
>> Is this a bug ? something else wrong ? mabye it's already fixt. Or mabye
>> i need to fix something.
>>
>> MySql.Data.MySqlClient.MySqlException (0x80004005): Incorrect datetime
>> value: '1459532289' for column 'TMStamp' at row 1
>
>
> Its an issue with 0.9.0 already reported and still open on Mantis at
> http://opensimulator.org/mantis/view.php?id=7848
> and occurring on our own grid too.
>
> According to Jeff Kelly there, it looks like some Unix time stamp code
> has crept in where os_groups_invites.TMStamp is a MySQL TIMESTAMP
>
> I found various parts of OpenSim/Addons/Groups/GroupsModule.cs that
> use msg.timestamp = (uint)Util.UnixTimeSinceEpoch();
>
> You can mask (but not correct) the error by removing
> STRICT_TRANS_TABLES and strict settings in the MySQL my.ini file.
>
> _______________________________________________
If the bug get fixed in later 0.9 version it's not a problem. because
it's still empty grid setup. SO i can start with clean database.

---
This email has been checked for viruses by Avast antivirus software.
https://www.avast.com/antivirus

_______________________________________________
Opensim-dev mailing list
[hidden email]
http://opensimulator.org/cgi-bin/mailman/listinfo/opensim-dev
Loading...